]> arthur.barton.de Git - ngircd-alex.git/blob - contrib/ngircd.spec
- Neue Funktion Conn_SetServer().
[ngircd-alex.git] / contrib / ngircd.spec
1 %define name    ngircd
2 %define version CurrentCVS
3 %define release 1
4 %define prefix  %{_prefix}
5
6 Summary:      Next Generation Internet Relay Chat Daemon
7 Name:         %{name}
8 Version:      %{version}
9 Release:      %{release}
10 Copyright:    GPL
11 Group:        Networking/Daemons
12 URL:          http://arthur.ath.cx/~alex/ngircd/
13 Source:       %{name}-%{version}.tar.gz
14 Packager:     Sean Reifschneider <jafo-rpms@tummy.com>
15 BuildRoot:    /var/tmp/%{name}-root
16
17 %description
18 ngIRCd is a free open source daemon for Internet Relay Chat (IRC),
19 developed under the GNU General Public License (GPL). It's written from
20 scratch and is not based upon the original IRCd like many others.
21
22 Why should you use ngIRCd? Because ...
23
24    * ... there are no problems with servers on changing or non-static IP
25          addresses.
26    * ... there is a small and lean configuration file.
27    * ... there is a free, modern and open source C source code.
28    * ... it is still under active development. 
29
30 %prep
31 %setup
32 %build
33 %configure
34 make
35
36 %install
37 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
38 %makeinstall
39 (
40    cd "$RPM_BUILD_ROOT"
41    ( cd usr/sbin; mv *-ngircd ngircd )
42    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
43    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
44 )
45
46 %clean
47 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
48
49 %files
50 %defattr(755,root,root)
51 %doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README
52 %config(noreplace) /etc
53 %{_prefix}/sbin
54 %attr(644,root,root) %{_prefix}/share/man/