]> arthur.barton.de Git - ngircd-alex.git/blob - contrib/ngircd.spec
276a826f8aa751fe6abc1dcabe9eecaff8a214f5
[ngircd-alex.git] / contrib / ngircd.spec
1 %define name    ngircd
2 %define version dev
3 %define release 1
4 %define prefix  %{_prefix}
5
6 Summary:      A lightweight daemon for the Internet Relay Chat (IRC)
7 Name:         %{name}
8 Version:      %{version}
9 Release:      %{release}
10 Copyright:    GPL
11 Group:        Networking/Daemons
12 URL:          http://arthur.ath.cx/~alex/ngircd/
13 Source:       %{name}-%{version}.tar.gz
14 Packager:     Sean Reifschneider <jafo-rpms@tummy.com>
15 BuildRoot:    /var/tmp/%{name}-root
16
17 %description
18 ngIRCd is a free open source daemon for the Internet Relay Chat (IRC),
19 developed under the GNU General Public License (GPL). It's written from
20 scratch and is not based upon the original IRCd like many others.
21
22 Advantages:
23  - no problems with servers using changing/non-static IP addresses.
24  - small and lean configuration file.
25  - free, modern and open source C code.
26  - still under active development.
27
28 ngIRCd is compatible to the "original" ircd 2.10.3p3, so you can run
29 mixed networks.
30
31 %prep
32 %setup
33 %build
34 %configure
35 make
36
37 %install
38 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
39 %makeinstall
40 (
41    cd "$RPM_BUILD_ROOT"
42    ( cd usr/sbin; mv *-ngircd ngircd )
43    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
44    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
45 )
46
47 %clean
48 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
49
50 %files
51 %defattr(755,root,root)
52 %doc AUTHORS  COPYING  ChangeLog  INSTALL NEWS  README
53 %config(noreplace) /etc
54 %{_prefix}/sbin
55 %{_prefix}/share/man/