]> arthur.barton.de Git - ngircd-alex.git/blob - contrib/ngircd.spec
053cd419e277de677eb7ba00ada5ef75cd645da7
[ngircd-alex.git] / contrib / ngircd.spec
1 %define name    ngircd
2 %define version 26~rc1
3 %define release 1
4 %define prefix  %{_prefix}
5
6 Summary:      A lightweight daemon for the Internet Relay Chat (IRC)
7 Name:         %{name}
8 Version:      %{version}
9 Release:      %{release}
10 License:      GPLv2+
11 Group:        System Environment/Daemons
12 URL:          http://ngircd.barton.de/
13 Source:       %{name}-%{version}.tar.gz
14 BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15 BuildRequires:  zlib-devel, openssl-devel
16
17 %description
18 ngIRCd is a free, portable and lightweight Internet Relay Chat server for small
19 or private networks, developed under the GNU General Public License (GPL).
20
21 The server is quite easy to configure, can handle dynamic IP addresses, and
22 optionally supports IDENT, IPv6 connections, SSL-protected links, and PAM for
23 user authentication as well as character set conversion for legacy clients. The
24 server has been written from scratch and is not based on the forefather, the
25 daemon of IRCNet.
26
27
28 %prep
29 %setup -q
30 %build
31 %configure \
32   --with-zlib \
33   --with-openssl
34
35 make %{?_smp_mflags}
36
37 %install
38 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
39 %makeinstall
40 (
41    cd "$RPM_BUILD_ROOT"
42    ( cd usr/sbin; mv *-ngircd ngircd )
43    ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
44    ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
45    rm -fr usr/share/doc/ngircd
46 )
47
48 %clean
49 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
50
51 %files
52 %defattr(755,root,root)
53 %doc AUTHORS COPYING ChangeLog INSTALL.md NEWS README.md doc/*
54 %config(noreplace) /etc
55 %{_prefix}/sbin
56 %{_mandir}/man5/ngircd.conf*
57 %{_mandir}/man8/ngircd.8*