]> arthur.barton.de Git - netatalk.git/blobdiff - test/afpd/Makefile.am
New MySQL CNID backend
[netatalk.git] / test / afpd / Makefile.am
index cb870d0c06813c0b561cc2b5307ae5fe9434ccb6..f5109b8dd3f0658fa192e4c6f5cef851174335d4 100644 (file)
@@ -31,7 +31,6 @@ test_SOURCES =  test.c subtests.c afpfunc_helpers.c \
                                $(top_srcdir)/etc/afpd/file.c \
                                $(top_srcdir)/etc/afpd/filedir.c \
                                $(top_srcdir)/etc/afpd/fork.c \
-                               $(top_srcdir)/etc/afpd/gettok.c \
                                $(top_srcdir)/etc/afpd/hash.c \
                                $(top_srcdir)/etc/afpd/mangle.c \
                                $(top_srcdir)/etc/afpd/messages.c \
@@ -39,6 +38,8 @@ test_SOURCES =  test.c subtests.c afpfunc_helpers.c \
                                $(top_srcdir)/etc/afpd/ofork.c \
                                $(top_srcdir)/etc/afpd/quota.c \
                                $(top_srcdir)/etc/afpd/status.c \
+                               $(top_srcdir)/etc/afpd/spotlight.c \
+                               $(top_srcdir)/etc/afpd/spotlight_marshalling.c \
                                $(top_srcdir)/etc/afpd/switch.c \
                                $(top_srcdir)/etc/afpd/uam.c \
                                $(top_srcdir)/etc/afpd/unix.c \
@@ -52,7 +53,7 @@ test_CFLAGS = \
        -I$(top_srcdir)/etc/afpd \
        -I$(top_srcdir)/include \
        -I$(top_srcdir)/sys \
-       @ZEROCONF_CFLAGS@ @GSSAPI_CFLAGS@ \
+       @ZEROCONF_CFLAGS@ @GSSAPI_CFLAGS@ @KRB5_CFLAGS@\
        -DAPPLCNAME \
        -DSERVERTEXT=\"$(SERVERTEXT)/\" \
        -D_PATH_AFPDPWFILE=\"$(pkgconfdir)/afppasswd\" \
@@ -62,6 +63,15 @@ test_CFLAGS = \
 
 test_LDADD = \
        $(top_builddir)/libatalk/libatalk.la \
-       @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@
+       @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@ @MYSQL_LIBS@
 
 test_LDFLAGS = -export-dynamic
+
+if WITH_DTRACE
+DTRACE_OBJ = test-afp_dsi.o test-fork.o test-appl.o test-catsearch.o test-directory.o test-enumerate.o test-file.o test-filedir.o
+afp_dtrace.o: $(top_srcdir)/include/atalk/afp_dtrace.d $(DTRACE_OBJ)
+       if test -f afp_dtrace.o ; then rm -f afp_dtrace.o ; fi
+       $(LIBTOOL) --mode=execute dtrace -G -s $(top_srcdir)/include/atalk/afp_dtrace.d -o afp_dtrace.o $(DTRACE_OBJ)
+test_LDADD += afp_dtrace.o @DTRACE_LIBS@
+CLEANFILES += afp_dtrace.o
+endif