]> arthur.barton.de Git - netatalk.git/blobdiff - libevent/configure.in
Merge product-2-2
[netatalk.git] / libevent / configure.in
index d61390bd68c6c7b76d4595cc1b6430fba5359544..285637b8d1ae5c0f02a9a40e4e26b41951600aa7 100644 (file)
@@ -11,9 +11,11 @@ AC_INIT(event.c)
 
 AC_CONFIG_MACRO_DIR([m4])
 
-AM_INIT_AUTOMAKE(libevent,2.0.17-stable)
+AM_INIT_AUTOMAKE(libevent,2.0.18-stable)
+dnl Enable silent Automake rules if present                                                                           
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
 AM_CONFIG_HEADER(config.h)
-AC_DEFINE(NUMERIC_VERSION, 0x02001100, [Numeric representation of the version])
+AC_DEFINE(NUMERIC_VERSION, 0x02001200, [Numeric representation of the version])
 
 dnl Initialize prefix.
 if test "$prefix" = "NONE"; then
@@ -154,6 +156,7 @@ else
 fi
 AC_SUBST(EV_LIB_WS32)
 AC_SUBST(EV_LIB_GDI)
+AC_SUBST(OPENSSL_LIBADD)
 
 AC_CHECK_HEADERS([openssl/bio.h])
 
@@ -164,10 +167,10 @@ OPENSSL_LIBS=""
 have_openssl=no
 AC_SEARCH_LIBS([SSL_new], [ssl],
        [have_openssl=yes
-       OPENSSL_LIBS="$LIBS -lcrypto $EV_LIB_GDI $EV_LIB_WS32"
+       OPENSSL_LIBS="$LIBS -lcrypto $EV_LIB_GDI $EV_LIB_WS32 $OPENSSL_LIBADD"
        AC_DEFINE(HAVE_OPENSSL, 1, [Define if the system has openssl])],
        [have_openssl=no],
-       [-lcrypto $EV_LIB_GDI $EV_LIB_WS32])
+       [-lcrypto $EV_LIB_GDI $EV_LIB_WS32 $OPENSSL_LIBADD])
 LIBS="$save_LIBS"
 AC_SUBST(OPENSSL_LIBS)
 fi
@@ -679,11 +682,6 @@ if test x$enable_gcc_warnings = xyes && test "$GCC" = "yes"; then
 #error
 #endif])], have_clang=yes, have_clang=no)
 
-  AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
-#if !defined(__clang__) || (__clang_major__ > 2) || (__clang_major__ == 2 && __clang_minor__ > 9)
-#error
-#endif])], have_clang29orlower=yes, have_clang29orlower=no)
-
   CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat -Wwrite-strings -Wmissing-declarations -Wredundant-decls -Wnested-externs -Wbad-function-cast -Wswitch-enum -Werror"
   CFLAGS="$CFLAGS -Wno-unused-parameter -Wstrict-aliasing"
 
@@ -698,10 +696,8 @@ if test x$enable_gcc_warnings = xyes && test "$GCC" = "yes"; then
     CFLAGS="$CFLAGS -Waddress"
   fi
 
-  if test x$have_gcc42 = xyes && test x$have_clang29orlower = xno; then
+  if test x$have_gcc42 = xyes && test x$have_clang = xno; then
     # These warnings break gcc 4.0.2 and clang, but work on gcc 4.2
-    # We only disable these for clang 2.9 and lower, in case they are
-    # supported in later versions.
     CFLAGS="$CFLAGS -Wnormalized=id -Woverride-init"
   fi