]> arthur.barton.de Git - netatalk.git/blobdiff - libevent/Makefile.am
Fix distcheck error caused by pkgconfig stuff
[netatalk.git] / libevent / Makefile.am
index 663035b6ca8eaf5a0a3c826b61ee4417c62522ac..8114ad3645182830e93861e8517c4539b07a7f89 100644 (file)
@@ -1,3 +1,9 @@
+# Makefile.am for libevent
+# Copyright 2000-2007 Niels Provos
+# Copyright 2007-2012 Niels Provos and Nick Mathewson
+#
+# See LICENSE for copying information.
+
 # 'foreign' means that we're not enforcing GNU package rules strictly.
 # '1.7' means that we need automake 1.7 or later (and we do).
 AUTOMAKE_OPTIONS = foreign 1.7
@@ -32,7 +38,7 @@ RELEASE = -release 2.0
 #
 # Once an RC is out, DO NOT MAKE ANY ABI-BREAKING CHANGES IN THAT SERIES
 # UNLESS YOU REALLY REALLY HAVE TO.
-VERSION_INFO = 6:1:1
+VERSION_INFO = 6:6:1
 
 # History:          RELEASE    VERSION_INFO
 #  2.0.1-alpha --     2.0        1:0:0
@@ -47,6 +53,12 @@ VERSION_INFO = 6:1:1
 #  2.0.10-stable--    2.0        5:1:0 (No ABI change)
 #  2.0.11-stable--    2.0        6:0:1 (ABI changed, backward-compatible)
 #  2.0.12-stable--    2.0        6:1:1 (No ABI change)
+#  2.0.13-stable--    2.0        6:2:1 (No ABI change)
+#  2.0.14-stable--    2.0        6:3:1 (No ABI change)
+#  2.0.15-stable--    2.0        6:3:1 (Forgot to update :( )
+#  2.0.16-stable--    2.0        6:4:1 (No ABI change)
+#  2.0.17-stable--    2.0        6:5:1 (No ABI change)
+#  2.0.18-stable--    2.0        6:6:1 (No ABI change)
 #
 # For Libevent 2.1:
 #  2.1.1-alpha --     2.1        1:0:0
@@ -70,10 +82,9 @@ VERSION_INFO = 6:1:1
 # is user-visible, and so we can pretty much guarantee that release
 # series won't be binary-compatible.
 
+if INSTALL_LIBEVENT
 dist_bin_SCRIPTS = event_rpcgen.py
-
-pkgconfigdir=$(libdir)/pkgconfig
-LIBEVENT_PKGCONFIG=libevent.pc
+endif
 
 # These sources are conditionally added by configure.in or conditionally
 # included from other files.
@@ -84,6 +95,7 @@ PLATFORM_DEPENDENT_SRC = \
 EXTRA_DIST = \
        LICENSE \
        autogen.sh \
+       event_rpcgen.py \
        libevent.pc.in \
        Doxyfile \
        whatsnew-2.0.txt \
@@ -93,16 +105,13 @@ EXTRA_DIST = \
 LIBEVENT_LIBS_LA = libevent.la libevent_core.la libevent_extra.la
 if PTHREADS
 LIBEVENT_LIBS_LA += libevent_pthreads.la
-LIBEVENT_PKGCONFIG += libevent_pthreads.pc
 endif
 if OPENSSL
 LIBEVENT_LIBS_LA += libevent_openssl.la
-LIBEVENT_PKGCONFIG += libevent_openssl.pc
 endif
 
 if INSTALL_LIBEVENT
 lib_LTLIBRARIES = $(LIBEVENT_LIBS_LA)
-pkgconfig_DATA = $(LIBEVENT_PKGCONFIG)
 else
 noinst_LTLIBRARIES =  $(LIBEVENT_LIBS_LA)
 endif
@@ -234,7 +243,7 @@ doxygen: FORCE
        doxygen $(srcdir)/Doxyfile
 FORCE:
 
-DISTCLEANFILES = *~ libevent.pc ./include/event2/event-config.h
+DISTCLEANFILES = *~ ./include/event2/event-config.h
 
 install: