]> arthur.barton.de Git - netatalk.git/blobdiff - libevent/Makefile.am
Add silent rules to libevent
[netatalk.git] / libevent / Makefile.am
index 663035b6ca8eaf5a0a3c826b61ee4417c62522ac..09505bd76688e62c073a84b4357b01d0af730fbe 100644 (file)
@@ -1,3 +1,9 @@
+# Makefile.am for libevent
+# Copyright 2000-2007 Niels Provos
+# Copyright 2007-2012 Niels Provos and Nick Mathewson
+#
+# See LICENSE for copying information.
+
 # 'foreign' means that we're not enforcing GNU package rules strictly.
 # '1.7' means that we need automake 1.7 or later (and we do).
 AUTOMAKE_OPTIONS = foreign 1.7
@@ -32,7 +38,7 @@ RELEASE = -release 2.0
 #
 # Once an RC is out, DO NOT MAKE ANY ABI-BREAKING CHANGES IN THAT SERIES
 # UNLESS YOU REALLY REALLY HAVE TO.
-VERSION_INFO = 6:1:1
+VERSION_INFO = 6:6:1
 
 # History:          RELEASE    VERSION_INFO
 #  2.0.1-alpha --     2.0        1:0:0
@@ -47,6 +53,12 @@ VERSION_INFO = 6:1:1
 #  2.0.10-stable--    2.0        5:1:0 (No ABI change)
 #  2.0.11-stable--    2.0        6:0:1 (ABI changed, backward-compatible)
 #  2.0.12-stable--    2.0        6:1:1 (No ABI change)
+#  2.0.13-stable--    2.0        6:2:1 (No ABI change)
+#  2.0.14-stable--    2.0        6:3:1 (No ABI change)
+#  2.0.15-stable--    2.0        6:3:1 (Forgot to update :( )
+#  2.0.16-stable--    2.0        6:4:1 (No ABI change)
+#  2.0.17-stable--    2.0        6:5:1 (No ABI change)
+#  2.0.18-stable--    2.0        6:6:1 (No ABI change)
 #
 # For Libevent 2.1:
 #  2.1.1-alpha --     2.1        1:0:0
@@ -70,7 +82,9 @@ VERSION_INFO = 6:1:1
 # is user-visible, and so we can pretty much guarantee that release
 # series won't be binary-compatible.
 
+if INSTALL_LIBEVENT
 dist_bin_SCRIPTS = event_rpcgen.py
+endif
 
 pkgconfigdir=$(libdir)/pkgconfig
 LIBEVENT_PKGCONFIG=libevent.pc
@@ -84,6 +98,7 @@ PLATFORM_DEPENDENT_SRC = \
 EXTRA_DIST = \
        LICENSE \
        autogen.sh \
+       event_rpcgen.py \
        libevent.pc.in \
        Doxyfile \
        whatsnew-2.0.txt \
@@ -181,7 +196,7 @@ NO_UNDEFINED =
 MAYBE_CORE =
 endif
 
-GENERIC_LDFLAGS = -static
+GENERIC_LDFLAGS = -version-info $(VERSION_INFO) $(RELEASE) $(NO_UNDEFINED)
 
 libevent_la_SOURCES = $(CORE_SRC) $(EXTRA_SRC)
 libevent_la_LIBADD = @LTLIBOBJS@ $(SYS_LIBS)
@@ -236,5 +251,3 @@ FORCE:
 
 DISTCLEANFILES = *~ libevent.pc ./include/event2/event-config.h
 
-install:
-