]> arthur.barton.de Git - netatalk.git/blobdiff - libatalk/Makefile.am
Spelling fixes
[netatalk.git] / libatalk / Makefile.am
index 10e0d505cfb33a79f37ee7ba06e687f4242b9c7a..ed597dcb5f0a608c389079722dd38bff5118cc8d 100644 (file)
 #               support?
 #
 # To increment a VERSION_INFO (current:revision:age):
-#    If the ABI didn't change:
-#        Return (current:revision+1:age)
+#    If the ABI didn't change, but any library code changed:
+#        current:revision+1:age
 #    If the ABI changed, but it's backward-compatible:
-#        Return (current+1:0:age+1)
+#        current+1:0:age+1
 #    If the ABI changed and it isn't backward-compatible:
-#        Return (current+1:0:0)
+#        current+1:0:0
 #
-# Once an RC is out, DO NOT MAKE ANY ABI-BREAKING CHANGES IN THAT SERIES
-# UNLESS YOU REALLY REALLY HAVE TO.
 
-VERSION_INFO = 1:0:0
+VERSION_INFO = 2:0:0
 
 # History:          VERSION_INFO
 #
@@ -28,6 +26,9 @@ VERSION_INFO = 1:0:0
 #   3.0.0-alpha2    0:0:0
 #   3.0.0-alpha3    0:0:0
 #   3.0.0-beta1     0:0:0
+#   3.0.0-beta2     1:0:0
+#   3.0             1:0:0
+#   3.0.1           2:0:0
 
 SUBDIRS = acl adouble bstring compat cnid dsi iniparser tdb util unicode vfs
 
@@ -83,3 +84,9 @@ all-local: .libs/libatalk.so
                exit 1 )
 
 endif
+
+EXTRA_DIST = \
+       libatalk-3.0beta1.abi \
+       libatalk-3.0beta2.abi \
+       libatalk-3.0.1.abi \
+       libatalk-3.0.abi