]> arthur.barton.de Git - netatalk.git/blobdiff - libatalk/Makefile.am
Update version history and VERSION_INFO description
[netatalk.git] / libatalk / Makefile.am
index cb1b6d2bf72500481d32528c8ba502ecb639bab5..03c7cf57990c100fcaabf6b970b04c6954ee21b5 100644 (file)
 #               support?
 #
 # To increment a VERSION_INFO (current:revision:age):
-#    If the ABI didn't change:
-#        Return (current:revision+1:age)
+#    If the ABI didn't change, but any library code changed:
+#        current:revision+1:age
 #    If the ABI changed, but it's backward-compatible:
-#        Return (current+1:0:age+1)
+#        current+1:0:age+1
 #    If the ABI changed and it isn't backward-compatible:
-#        Return (current+1:0:0)
+#        current+1:0:0
 #
-# Once an RC is out, DO NOT MAKE ANY ABI-BREAKING CHANGES IN THAT SERIES
-# UNLESS YOU REALLY REALLY HAVE TO.
 
 VERSION_INFO = 1:0:0
 
@@ -28,6 +26,7 @@ VERSION_INFO = 1:0:0
 #   3.0.0-alpha2    0:0:0
 #   3.0.0-alpha3    0:0:0
 #   3.0.0-beta1     0:0:0
+#   3.0.0-beta2     1:0:0
 
 SUBDIRS = acl adouble bstring compat cnid dsi iniparser tdb util unicode vfs