]> arthur.barton.de Git - netatalk.git/blobdiff - include/atalk/Makefile.am
Merge remote-tracking branch 'origin/branch-netatalk-3-0' into develop
[netatalk.git] / include / atalk / Makefile.am
index a8f47137720a29d7eb5539e3df953e2f6ca763d0..2f63e0f676e76edea239c6738f93c6751e3522e4 100644 (file)
@@ -1,6 +1,8 @@
 # Makefile.am for include/atalk/
 
 atalkincludedir = $(includedir)/atalk
+BUILT_SOURCES = 
+CLEANFILES =
 
 atalkinclude_HEADERS = \
        adouble.h \
@@ -8,35 +10,49 @@ atalkinclude_HEADERS = \
        vfs.h \
        cnid.h \
        logger.h \
+       netatalk_conf.h \
        paths.h \
        unicode.h \
        util.h \
-       volinfo.h \
        ea.h \
        acl.h \
        unix.h \
-       volume.h
+       volume.h \
+       standards.h \
+       bstrlib.h \
+       list.h \
+       globals.h \
+       compat.h \
+       uam.h \
+       iniparser.h \
+       dictionary.h \
+       hash.h
 
 noinst_HEADERS = \
        directory.h \
-       hash.h \
-       zip.h \
        uuid.h \
        queue.h \
        server_child.h \
        server_ipc.h \
        tdb.h \
-       uam.h \
        cnid_dbd_private.h \
        cnid_private.h \
        bstradd.h \
-       bstrlib.h \
        errchk.h \
        ftw.h \
-       compat.h \
        dsi.h \
        ldapconfig.h \
-       list.h \
-       globals.h \
+       talloc.h \
+       dalloc.h \
+       byteorder.h \
        fce_api.h \
-       standards.h
+       spotlight.h
+
+EXTRA_DIST = afp_dtrace.d
+
+if WITH_DTRACE
+BUILT_SOURCES += afp_dtrace.h
+CLEANFILES += afp_dtrace.h
+afp_dtrace.h: $(top_srcdir)/include/atalk/afp_dtrace.d
+       $(LIBTOOL) --mode=execute dtrace -o afp_dtrace.h -h -s $(top_srcdir)/include/atalk/afp_dtrace.d
+endif