]> arthur.barton.de Git - netatalk.git/blobdiff - etc/afpd/Makefile.am
First working IPC reconnect
[netatalk.git] / etc / afpd / Makefile.am
index f4d04f1a907d6dc2506c5bc40c5af1a77ae41d88..5dd97e438638f52877994e32fb35d54ed6c848b3 100644 (file)
@@ -5,34 +5,73 @@ pkgconfdir = @PKGCONFDIR@
 sbin_PROGRAMS = afpd
 noinst_PROGRAMS = hash
 
-afpd_SOURCES = unix.c ofork.c main.c switch.c auth.c volume.c directory.c \
-        file.c enumerate.c desktop.c filedir.c fork.c appl.c gettok.c \
-        mangle.c status.c afp_options.c afp_asp.c afp_dsi.c messages.c  \
-        afp_config.c nfsquota.c quota.c uam.c afs.c uid.c afp_util.c \
-       catsearch.c afprun.c hash.c extattrs.c dircache.c
+afpd_SOURCES = \
+       afp_asp.c \
+       afp_avahi.c \
+       afp_config.c \
+       afp_dsi.c \
+       afp_options.c \
+       afp_util.c \
+       afp_zeroconf.c \
+       afprun.c \
+       afs.c \
+       appl.c \
+       auth.c \
+       catsearch.c \
+       desktop.c \
+       dircache.c \
+       directory.c \
+       enumerate.c \
+       extattrs.c \
+       file.c \
+       filedir.c \
+       fork.c \
+       gettok.c \
+       hash.c \
+       main.c \
+       mangle.c \
+       messages.c  \
+       nfsquota.c \
+       ofork.c \
+       quota.c \
+       status.c \
+       switch.c \
+       uam.c \
+       uid.c \
+       unix.c \
+       volume.c
 
-if USE_NFSv4_ACLS
+afpd_LDADD =  \
+       $(top_builddir)/libatalk/cnid/libcnid.la \
+       $(top_builddir)/libatalk/libatalk.la \
+       @LIBGCRYPT_LIBS@ @ZEROCONF_LIBS@ @QUOTA_LIBS@ @SLP_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @PTHREAD_LIBS@
+
+afpd_LDFLAGS = -export-dynamic 
+
+afpd_CFLAGS = \
+       -I$(top_srcdir)/include \
+       -I$(top_srcdir)/sys \
+       @SLP_CFLAGS@ @ZEROCONF_CFLAGS@ \
+       -DAPPLCNAME \
+       -DSERVERTEXT=\"$(SERVERTEXT)/\" \
+       -D_PATH_AFPDDEFVOL=\"$(pkgconfdir)/AppleVolumes.default\" \
+       -D_PATH_AFPDSYSVOL=\"$(pkgconfdir)/AppleVolumes.system\" \
+       -D_PATH_AFPDPWFILE=\"$(pkgconfdir)/afppasswd\" \
+       -D_PATH_AFPDCONF=\"$(pkgconfdir)/afpd.conf\" \
+       -D_PATH_AFPDSIGCONF=\"$(pkgconfdir)/afp_signature.conf\" \
+       -D_PATH_AFPDUAMPATH=\"$(UAMS_PATH)/\" \
+       -D_PATH_ACL_LDAPCONF=\"$(pkgconfdir)/afp_ldap.conf\" \
+       -D_PATH_AFPDUUIDCONF=\"$(pkgconfdir)/afp_voluuid.conf\"
+
+if HAVE_ACLS
 afpd_SOURCES += acls.c
 endif
 
-afpd_LDADD =  $(top_builddir)/libatalk/cnid/libcnid.la $(top_builddir)/libatalk/libatalk.la @QUOTA_LIBS@ @SLP_LIBS@ @WRAP_LIBS@ @LIBADD_DL@
-afpd_LDFLAGS = -export-dynamic 
-afpd_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/sys \
-        @SLP_CFLAGS@ \
-        -D_PATH_AFPDDEFVOL=\"$(pkgconfdir)/AppleVolumes.default\" \
-        -D_PATH_AFPDSYSVOL=\"$(pkgconfdir)/AppleVolumes.system\" \
-        -D_PATH_AFPDPWFILE=\"$(pkgconfdir)/afppasswd\" \
-        -D_PATH_AFPDCONF=\"$(pkgconfdir)/afpd.conf\" \
-        -D_PATH_AFPDSIGCONF=\"$(pkgconfdir)/afp_signature.conf\" \
-        -D_PATH_AFPDUAMPATH=\"$(UAMS_PATH)/\" \
-        -D_PATH_ACL_LDAPCONF=\"$(pkgconfdir)/afp_ldap.conf\" \
-        -DAPPLCNAME \
-        -DSERVERTEXT=\"$(SERVERTEXT)/\"
 
 noinst_HEADERS = auth.h afp_config.h desktop.h directory.h file.h \
-        filedir.h fork.h globals.h icon.h mangle.h misc.h status.h switch.h \
+        filedir.h fork.h icon.h mangle.h misc.h status.h switch.h \
         uam_auth.h uid.h unix.h volume.h hash.h acls.h acl_mappings.h extattrs.h \
-        dircache.h
+        dircache.h afp_zeroconf.h afp_avahi.h
 
 hash_SOURCES = hash.c
 hash_CFLAGS = -DKAZLIB_TEST_MAIN -I$(top_srcdir)/include