]> arthur.barton.de Git - netatalk.git/blobdiff - doc/Makefile.am
Add html manual generation
[netatalk.git] / doc / Makefile.am
index e4e156e30dd5488c7cca5cddef2263428d97bccf..f327c01a120eac08edaf990b9dd358b75dc55c4a 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS =
+SUBDIRS = manpages manual
 XSLTPROC=@XSLTPROC@
 XSLTPROC_FLAGS=@XSLTPROC_FLAGS@
 XHTML_STYLESHEET=$(top_srcdir)/doc/html.xsl
@@ -6,9 +6,10 @@ XHTML_STYLESHEET=$(top_srcdir)/doc/html.xsl
 htmldir = $(prefix)/share/doc/@PACKAGE@
 dist_html_DATA = @PACKAGE@.html
 
-if HAVE_XSLTPROC
-       SUBDIRS += manpages
-endif
+DISTCLEANFILES = html.xsl man.xsl
 
-distclean-local:
-       $(RM) -f $(top_builddir)/doc/html.xsl $(top_builddir)/doc/html.xsl $(top_builddir)/doc/manual/manual.xml
+release-notes: www/ReleaseNotes
+       cd www && ./create-relnotes.sh
+
+upload-release-notes: release-notes
+       scp www/ReleaseNotes.html $$USER,netatalk@web.sourceforge.net:/home/project-web/netatalk/htdocs/3.0/ReleaseNotes$(VERSION).html