]> arthur.barton.de Git - netatalk.git/blobdiff - doc/Makefile.am
Add html manual generation
[netatalk.git] / doc / Makefile.am
index 3a9648c9113b531edfb7c40590a52292560ba7ad..f327c01a120eac08edaf990b9dd358b75dc55c4a 100644 (file)
@@ -1,12 +1,15 @@
-# Makefile.am for INSTALL/
-
-EXTRA_DIST = \
-       CONFIGURE       \
-       COPYRIGHT.mtab  \
-       DEVELOPER       \
-       INSTALL         \
-       FAQ             \
-       README.mtab             \
-       README.mtab.distribution \
-       README.platforms        \
-       README.veto
+SUBDIRS = manpages manual
+XSLTPROC=@XSLTPROC@
+XSLTPROC_FLAGS=@XSLTPROC_FLAGS@
+XHTML_STYLESHEET=$(top_srcdir)/doc/html.xsl
+
+htmldir = $(prefix)/share/doc/@PACKAGE@
+dist_html_DATA = @PACKAGE@.html
+
+DISTCLEANFILES = html.xsl man.xsl
+
+release-notes: www/ReleaseNotes
+       cd www && ./create-relnotes.sh
+
+upload-release-notes: release-notes
+       scp www/ReleaseNotes.html $$USER,netatalk@web.sourceforge.net:/home/project-web/netatalk/htdocs/3.0/ReleaseNotes$(VERSION).html