]> arthur.barton.de Git - netatalk.git/blobdiff - distrib/initscripts/Makefile.am
Revert changes back to 1.16.6.8.2.1, the fix will only appear in HEAD
[netatalk.git] / distrib / initscripts / Makefile.am
index 2d744a58deb87c7dc3d6de865e09bd5a70650e39..ecc150b28ea33151cd1f6973b63480714931e775 100644 (file)
@@ -21,14 +21,35 @@ GENERATED_FILES = \
        rc.atalk.bsd            \
        rc.atalkd.netbsd        \
        rc.atalk.suse           \
+       rc.cnid_metad.netbsd    \
        rc.papd.netbsd          \
-       rc.timelord.netbsd
-TEMPLATES = $(foreach f,$(GENERATED_FILES),$(f).tmpl)
-
-CLEANFILES = $(GENERATED_FILES)
-EXTRA_DIST = $(TEMPLATES) rc.atalk.cobalt rc.atalk.sysv
-
-install-data-hook: $(GENERATED_FILES)
+       rc.timelord.netbsd      \
+       rc.atalk.sysv           \
+       rc.atalk.gentoo         \
+       rc.atalk.debian
+
+TEMPLATES = \
+       rc.afpd.netbsd.tmpl             \
+       rc.atalk.redhat.tmpl            \
+       rc.atalk.tru64.tmpl             \
+       rc.atalk.bsd.tmpl               \
+       rc.atalkd.netbsd.tmpl           \
+       rc.atalk.suse.tmpl              \
+       rc.cnid_metad.netbsd.tmpl       \
+       rc.papd.netbsd.tmpl             \
+       rc.timelord.netbsd.tmpl         \
+       rc.atalk.sysv.tmpl              \
+       rc.atalk.gentoo.tmpl            \
+       rc.atalk.debian.tmpl
+
+CLEANFILES = $(GENERATED_FILES) atalk afpd atalkd papd timelord
+EXTRA_DIST = $(TEMPLATES) rc.atalk.cobalt
+
+# overwrite automake uninstall
+# not beautiful, but this way we can call the OS specific init script
+# tools, like chkconfig, insserv or rc-update
+
+uninstall: uninstall-startup
 
 #
 # checking for "redhat" style sysv scripts:
@@ -43,6 +64,13 @@ atalk: rc.atalk.redhat
        cp -f rc.atalk.redhat atalk
        chmod a+x atalk
 
+install-data-hook:
+       -chkconfig --add atalk
+
+uninstall-startup:
+       -chkconfig --del atalk
+       rm -f /etc/rc.d/init.d/atalk
+
 endif
 
 #
@@ -58,9 +86,15 @@ atalk: rc.atalk.suse
        cp -f rc.atalk.suse atalk
        chmod a+x atalk
 
+install-data-hook:
+       -insserv atalk
+
+uninstall-startup:
+       -insserv -d atalk
+       rm -f /etc/init.d/atalk
+
 endif
 
-#
 #
 # checking for "cobalt" style sysv scripts:
 #
@@ -74,6 +108,12 @@ atalk: rc.atalk.cobalt
        cp -f rc.atalk.cobalt atalk
        chmod a+x atalk
 
+install-data-hook:
+
+uninstall-hook:
+
+uninstall-startup: uninstall-am
+
 endif
 
 #
@@ -89,6 +129,12 @@ atalk: rc.atalk.tru64
        cp -f rc.atalk.tru64 atalk
        chmod a+x atalk
 
+install-data-hook:
+
+uninstall-hook:
+
+uninstall-startup: uninstall-am
+
 endif
 
 #
@@ -98,7 +144,7 @@ endif
 if USE_NETBSD
 
 sysvdir = /etc/rc.d
-sysv_SCRIPTS = afp atalk pap timelord
+sysv_SCRIPTS = afpd atalkd papd timelord
 
 afpd: rc.afpd.netbsd
        cp -f $< $@
@@ -115,5 +161,93 @@ timelord: rc.timelord.netbsd
        cp -f $< $@
        chmod a+x $@
 
+install-data-hook:
+
+uninstall-hook:
+
+uninstall-startup: uninstall-am
+
+endif
+
+#
+# checking for Solaris init scripts
+#
+
+if USE_SOLARIS
+
+sysvdir = /etc/init.d
+sysv_SCRIPTS = atalk
+
+atalk: rc.atalk.sysv
+       cp -f rc.atalk.sysv $@
+       chmod a+x $@
+
+install-data-hook:
+       rm -f /etc/rc2.d/S90atalk
+       -ln -s ../init.d/atalk /etc/rc2.d/S90atalk
+       rm -f /etc/rc0.d/K04atalk
+       -ln -s ../init.d/atalk /etc/rc0.d/K04atalk
+
+uninstall-startup:
+       rm -f /etc/init.d/atalk /etc/rc2.d/S90atalk /etc/rc0.d/K04atalk
+
+endif
+
+#
+# checking for "Gentoo" style sysv scripts:
+#
+
+if USE_GENTOO
+
+sysvdir = /etc/init.d
+sysv_SCRIPTS = atalk
+
+atalk: rc.atalk.gentoo
+       cp -f rc.atalk.gentoo atalk
+       chmod a+x atalk
+
+install-data-hook:
+       -rc-update add atalk default
+
+uninstall-startup:
+       -rc-update del atalk default
+       rm -f /etc/init.d/atalk
+
+endif
+
+#
+# checking for "Debian" style sysv scripts:
+#
+
+if USE_DEBIAN
+
+sysvdir = /etc/init.d
+sysv_SCRIPTS = atalk
+
+atalk: rc.atalk.debian
+       cp -f rc.atalk.debian atalk
+       chmod a+x atalk
+
+install-data-hook:
+       update-rc.d atalk defaults 90 10
+
+uninstall-startup:
+       rm -f /etc/init.d/atalk
+       update-rc.d atalk remove
+
+endif
+
+#
+# defaults, no init scripts installed
+#
+
+if USE_UNDEF
+
+install-data-hook:
+
+uninstall-hook:
+
+uninstall-startup: uninstall-am
+
 endif