get: adjust for python 3 and test there