]> arthur.barton.de Git - netdata.git/blobdiff - contrib/debian/rules
Merge branch 'master' into ab-debian
[netdata.git] / contrib / debian / rules
index ec4ec41821b9b58e8bb487fc519b06915c59e803..6b417d33088ac6604cc62175b6591d5adf9b2d6e 100755 (executable)
@@ -25,6 +25,11 @@ debian/%.postinst: debian/%.postinst.in
 override_dh_install: debian/netdata.postinst
        dh_install
 
+       # Set correct version (Git commit id) when called by the
+       # contrib/debian/build-new-package.sh script:
+       #
+       [ -z "$$COMMIT_ID" ] || echo "$$COMMIT_ID" >$(TOP)/var/lib/netdata/www/version.txt
+
        # Remove unneeded .keep files
        #
        find "$(TOP)" -name .keep -exec rm '{}' ';'