]> arthur.barton.de Git - netatalk.git/blob - distrib/rpm/netatalk-redhat.spec
1.5pre6 versions of spec files
[netatalk.git] / distrib / rpm / netatalk-redhat.spec
1 #################################################### VERSIONING INFORMATION
2 %define name    netatalk
3 %define version 1.5pre6
4 %define release 1
5
6 ################################################# BASIC PACKAGE INFORMATION
7 Summary: Appletalk and Appleshare/IP services for Linux
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Copyright: BSD
12 Group: Networking/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 URL: http://netatalk.sourceforge.net/
15 Packager: rufus t firefly <rufus.t.firefly@linux-mandrake.com>
16 Obsoletes: netatalk-1.4b2+asun netatalk-1.4.99
17
18 ############################################################## REQUIREMENTS
19 Requires: cracklib, openssl, tcp_wrappers, pam
20 BuildRequires: openssl-devel
21
22 Prefix:    %{_prefix}
23 BuildRoot: /var/tmp/%{name}-buildroot
24
25 %description
26 netatalk is an implementation of the AppleTalk Protocol Suite for Unix/Linux
27 systems. The current release contains support for Ethertalk Phase I and II,
28 DDP, RTMP, NBP, ZIP, AEP, ATP, PAP, ASP, and AFP. It provides Appletalk file
29 printing and routing services on Solaris 2.5, Linux, FreeBSD, SunOS 4.1 and
30 Ultrix 4. It also supports AFP 2.1 and 2.2 (Appleshare IP).
31
32 %package devel
33 Group: Development/Networking
34 Summary: Appletalk and Appleshare/IP services for Linux development files
35 %description devel
36 netatalk is an implementation of the AppleTalk Protocol Suite for Unix/Linux
37 systems. The current release contains support for Ethertalk Phase I and II,
38 DDP, RTMP, NBP, ZIP, AEP, ATP, PAP, ASP, and AFP. It provides Appletalk file
39 printing and routing services on Solaris 2.5, Linux, FreeBSD, SunOS 4.1 and
40 Ultrix 4. It also supports AFP 2.1 and 2.2 (Appleshare IP).
41
42 This package is required for developing appletalk-based applications.
43
44 %changelog
45
46 * Thu Apr 12 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
47   - v1.5pre6-1
48   - pre-release 6 for sourceforge
49
50 * Wed Mar 07 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
51   - v1.5pre5-1
52   - pre-release 5 for sourceforge
53
54 * Fri Feb 23 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
55   - v1.5pre5-0
56   - pre-release 5 for sourceforge (prebuild)
57
58 * Tue Feb 20 2001 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
59   - v1.5pre4-1
60   - pre-release 4 for sourceforge
61   - modified/split mandrake spec for redhat 7 build
62
63 * Mon Dec 18 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
64   - v1.5pre3-1mdk
65   - pre-release 3 for sourceforge
66   - moved away from 1.4.99 ... 
67
68 * Wed Nov 08 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
69   - v1.4.99-0.20001108mdk
70   - pre-release 2 for sourceforge
71
72 * Wed Sep 27 2000 rufus t firefly <rufus.t.firefly@linux-mandrake.com>
73   - v1.4.99-0.20000927mdk
74   - pre-release 1 for sourceforge
75
76 %prep
77 %setup -q -n %{name}-%{version}/
78
79 %build
80 CFLAGS="$RPM_OPT_FLAGS -fomit-frame-pointer -fsigned-char" ./configure \
81         --prefix=%{prefix} \
82         --with-config-dir=/etc/atalk \
83         --with-uams-path=/etc/atalk/uams \
84         --with-msg-dir=/etc/atalk/msg \
85         --enable-lastdid \
86         --enable-redhat \
87         --with-cracklib \
88         --with-pam \
89         --with-shadow \
90         --with-tcp-wrappers \
91         --with-ssl \
92         --enable-pgp-uam
93 make all
94
95 %install
96 ### INSTALL (USING "make install") ###
97 mkdir -p $RPM_BUILD_ROOT{%{prefix},/etc/atalk/{uams,msg}}
98 make DESTDIR=$RPM_BUILD_ROOT install-strip
99
100 # bzip2 man pages
101 #for i in 1 3 4 5 8; do
102 #       bzip2 -v $RPM_BUILD_ROOT/usr/man/man$i/*.$i
103 #done
104
105 %post
106 ### RUN CHKCONFIG ###
107 /sbin/chkconfig --add atalk
108 /sbin/ldconfig
109 # after the first install only
110 if [ "$1" = 1 ]; then
111         # add the ddp lines to /etc/services
112         if (grep '[0-9][0-9]*/ddp' /etc/services >/dev/null); then
113                 cat <<'_EOD1_' >&2
114 warning: The DDP services appear to be present in /etc/services.
115 warning: Please check them against services.atalk in the documentation.
116 _EOD1_
117                 true
118         else
119                 cat <<'_EOD2_' >>/etc/services
120 # start of DDP services
121 #
122 # Everything between the 'start of DDP services' and 'end of DDP services'
123 # lines will be automatically deleted when the netatalk package is removed.
124 #
125 rtmp            1/ddp           # Routing Table Maintenance Protocol
126 nbp             2/ddp           # Name Binding Protocol
127 echo            4/ddp           # AppleTalk Echo Protocol
128 zip             6/ddp           # Zone Information Protocol
129
130 afpovertcp      548/tcp         # AFP over TCP
131 afpovertcp      548/udp
132 # end of DDP services
133 _EOD2_
134         fi
135 fi
136
137 %preun
138 ### RUN CHKCONFIG ###
139 /sbin/chkconfig --del atalk
140
141 %postun
142 # do only for the last un-install
143 if [ "$1" = 0 ]; then
144         # remove the ddp lines from /etc/services
145         if (grep '^# start of DDP services$' /etc/services >/dev/null && \
146             grep '^# end of DDP services$'   /etc/services >/dev/null ); then
147           sed -e '/^# start of DDP services$/,/^# end of DDP services$/d' \
148             </etc/services >/tmp/services.tmp$$
149           cat /tmp/services.tmp$$ >/etc/services
150           rm /tmp/services.tmp$$
151         else
152           cat <<'_EOD3_' >&2
153 warning: Unable to find the lines `# start of DDP services` and
154 warning: `# end of DDP services` in the file /etc/services.
155 warning: You should remove the DDP services from /etc/services manually.
156 _EOD3_
157         fi
158 fi
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162 rm -rf $RPM_BUILD_DIR/%{name}/
163
164 %files
165 %defattr(-,root,root)
166 %doc doc/[A-L,N-Z]*
167 %config /etc/atalk/Apple*
168 %config /etc/atalk/*.conf
169 %config /etc/pam.d/netatalk
170 /etc/atalk/nls/*
171 /etc/atalk/uams/*.so
172 /etc/rc.d/init.d/atalk
173 %dir /etc/atalk
174 %dir /etc/atalk/nls
175 %dir /etc/atalk/uams
176 %{prefix}/bin/*
177 %{prefix}/sbin/*
178 %{prefix}/man/man*/*
179
180 %files devel
181 %defattr(-,root,root)
182 %{prefix}/lib/*.a
183 %dir %{prefix}/include/atalk
184 %{prefix}/include/atalk/*.h
185 %dir %{prefix}/include/netatalk
186 %{prefix}/include/netatalk/*.h
187 %{prefix}/share/aclocal/netatalk.m4