]> arthur.barton.de Git - ngircd.git/blobdiff - contrib/Debian/Makefile.am
Update included Debian package configuration
[ngircd.git] / contrib / Debian / Makefile.am
index 2cd5277ca26e1ac5f3bf2db19693aea0d8a40e72..bbc715ff715f41e9cb29d15ff87bcfdfc53bc1fe 100644 (file)
@@ -1,6 +1,6 @@
 #
 # ngIRCd -- The Next Generation IRC Daemon
-# Copyright (c)2001-2017 Alexander Barton (alex@barton.de) and Contributors
+# Copyright (c)2001-2024 Alexander Barton (alex@barton.de) and Contributors
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -9,22 +9,22 @@
 # Please read the file COPYING, README and AUTHORS for more information.
 #
 
-EXTRA_DIST = rules changelog compat control copyright \
-       ngircd.init ngircd.default ngircd.pam ngircd.postinst \
+EXTRA_DIST = \
+       changelog \
+       control \
+       copyright \
+       ngircd.default \
+       ngircd.pam \
+       rules \
+       watch \
        source/format
 
 maintainer-clean-local:
        rm -f Makefile Makefile.in
 
 clean-local:
-       rm -f ngircd.postinst.debhelper ngircd.postrm.debhelper \
-        ngircd.prerm.debhelper ngircd.substvars
-       rm -f ngircd-full.postinst.debhelper ngircd-full.postrm.debhelper \
-        ngircd-full.prerm.debhelper ngircd-full.substvars
-       rm -f ngircd-full-dbg.postinst.debhelper \
-        ngircd-full-dbg.postrm.debhelper ngircd-full-dbg.prerm.debhelper \
-        ngircd-full-dbg.substvars
-       rm -rf ngircd ngircd-full ngircd-full-dbg
-       rm -f files
+       rm -f *.log *.debhelper *.substvars
+       rm -f debhelper-build-stamp files ngircd.service
+       rm -rf .debhelper/ ngircd/
 
 # -eof-